[wplug] floppy disk rescue

Arnaud Loos arnaud at arnaudloos.com
Tue Nov 28 14:04:30 EST 2006

Thanks for the help everyone. I'm still running into a few problems though.

I'm able to successfully create the dd image (I found a script called
dd_rhelp which uses dd_rescue but seems more thorough). I also used
Jonathan's suggested method to create a second image. When I try and mount
either image on loopback using -o loop, I receive an error stating that I
must specify a filesystem type. Using -t with both vfat and msdos results in
the same error "wrong fs type, bad option, bad superblock on /dev/loop0".
Running dmesg shows "can't find a valid FAT filesystem on dev loop0".

I've tried running fsck.msdos on the unmounted image (which is I believe the
suggested method) but receive an input/output error. I believe I have a
rather good image which I would be able to extract data from, but I can't
get it mounted. Any suggestions?

As I stated before, I am able to mount the disk itself, but after 8K of a
28K file, cp errors out. Is there another copy program or switch which would
be able to skip over the bad block and continue copying the rest of the
file? I'd be more than happy recovering most of the file with a few blocks
worth of info missing in the middle.


-----Original Message-----
From: Alexandros Papadopoulos [mailto:apapadop at alumni.cmu.edu] 
Sent: Tuesday, November 28, 2006 11:16 AM
To: General user list
Subject: Re: [wplug] floppy disk rescue

On Tuesday 28 November 2006 16:01, Zach wrote:
> On 11/28/06, Jonathan S. Billings <billings at negate.org> wrote:
> > mount -o loop /path/to/floppy.img /mnt/floppy
> What is the benefit of using the loopback versus just mounting it
> without the "-o loop"?

Can't do it any other way. A dd image is not a real device. The loopback 
driver allows you to emulate physical storage devices using plain files.

wplug mailing list
wplug at wplug.org

More information about the wplug mailing list