[wplug] Broken Mandrake

Elwin Green bekitemba at excite.com
Wed Nov 28 02:25:12 EST 2001

Greetings, all:

I have a multi-boot machine with Win98, Mandrake 7.0, and Peanut Linux 8.4
installed. My hard drives are arranged thus:

hda1: W98 partition
hda2: W98 extended partition
hda3: Mandrake
hda4: Mandrake swap
hda5: W98 logical partition
No hdb
hdc1: W98 partition
hdc2: Peanut
hdd: CDROM

Yesterday morning, for reasons I still don't know, Mandrake shut down. When
I tried to reboot, it froze during startup.

At first I thought it had something to do with me editing Mandrake's fstab,
mtab and the CDROM's KDE desktop icon. I logged on to Peanut Linux as root
and was able to access Mandrake from there and to correct anything that
looked wrong in fstab. When I rebooted Mandrake again, it froze again at the
same spot.

This is the sequence of messages immediately before it hangs:

VFS: mounted root readonly
Checking root filesystem
/dev/hda3 not cleanly unmounted, eheck forced
(it checks hda3, then:)
Remounting root filesystem in read-write mode.

That's where it stops, and where I wind up resetting..

Any suggestions, anyone? Thanks!

Elwin G.

PS, in case this is relevant: I tried booting from floppy with tomsrtbt and
mounting hda3 by adding this line to fstab and performing mount -a:
	/dev/hda3 /mnt ext2 defaults 0 0
and got these messages:
EXT2-fs: 03:03 couldn't mount because of unsupported optional features
mount: wrong fs type, bad option, bad superblock on /dev/hdae, or too many
mounted file systems.


More information about the wplug mailing list