[wplug-bsd] new disk help

Tom Rhodes trhodes at FreeBSD.org
Wed Sep 27 21:57:53 EDT 2006

On Wed, 27 Sep 2006 21:51:54 -0400 (EDT)
Brandon Kuczenski <brandon at 301south.net> wrote:

> I recently tried to install a new HDD to my system.  I formatted the HDD 
> using a FreeSBIE 1.1 live-cd distribution (running FreeBSD 5.3).  I used 
> the entire disk with a single partition and formatted it with ufs.
> I ran 'newfs' on the system and then copied all my files onto it over the 
> network.
> Then I put it into my FreeBSD 4.11 system and I can't mount it.
> Here is the fdisk info:
> # fdisk /dev/ad1
> ******* Working on device /dev/ad1 *******
> parameters extracted from in-core disklabel are:
> cylinders=19929 heads=255 sectors/track=63 (16065 blks/cyl)
> Figures below won't work with BIOS for partitions not in cyl 1
> parameters to be used for BIOS calculations are:
> cylinders=19929 heads=255 sectors/track=63 (16065 blks/cyl)
> Media sector size is 512
> Warning: BIOS sector numbering starts with sector 1
> Information from DOS bootblock is:
> The data for partition 1 is:
> sysid 165,(FreeBSD/NetBSD/386BSD)
>      start 63, size 320159322 (156327 Meg), flag 80 (active)
>  	beg: cyl 0/ head 1/ sector 1;
>  	end: cyl 1023/ head 254/ sector 63
> The data for partition 2 is:
> The data for partition 3 is:
> The data for partition 4 is:
> The disk was mounted as /dev/ad2s1 on the 5.3 system.  But that gives an 
> 'invalid superblock' error on the 4.11 system.
> # mount /dev/ad1
> mount: /dev/ad1 on /home: incorrect super block
> # mount /dev/ad1s1
> mount: /dev/ad1s1 on /home: incorrect super block
> Can anyone clue me in on this?
> Please CC responses to root at 301south.net, since my user's home directory 
> is on the [unmounted] disk.

Yes.  FreeBSD 5X and later use the UFS2 file system, which
was created to handle additions to the super block - mainly it
added support for things like FS ACLs, a chance for MAC
labels to be stored in the superblock (but never will be),

Unfortunately, while UFS2 is backward compatible with the
original UFS, older versions of FreeBSD cannot understand the
UFS2 structures.

To create an original UFS, add "-O 1" to the newfs options,
or in sysinstall; however you're doing it.

If you still have problems please let me know.  Thanks,

Tom Rhodes

More information about the wplug-bsd mailing list